关于iOS应用中类库不支持新机器(例armv7s)的解决办法

 

错误:linker command failed with exit code 1 (use -v to see invocation)

 

发现主要是对几个第三方类库的不支持(比如lMobClickLibrary友盟,GDataXMLNode或者Admob类库神马的,具体是哪一个不支持就不清楚了)。

其中armv7s代表iphone5。

解决方法如下:

如图,通过PROJECT-Build Setting,然后把Build Active Architecture Only的值设置为Yes。

或者把Valid Architectures的值中的armv7s删除。

然后就只有静待第三方类库支持iOS6和iPhone5了。

 

标签:
,,,
分类:iOS开发 | 发布:inzaghi | 评论:0 条 | 发表时间:2014-03-18 11:17
引用:点击这里获取该日志的TrackBack引用地址
上一篇:
下一篇:

发表评论

*

* 绝不会泄露


Design By Inzaghi | 京ICP备16047555号-1